Upgrading to iOS5 causes ‘No Provisioned iOS devices are available’ error

I finally decided to upgrade my iPhone to iOS 5 today. The upgrade process was pretty smooth, but once it was done, I was no longer able to run the apps from XCode. I kept getting the no provisioned ios devices are available with a compatible ios version error.

Turned out that all I had to do was to go to Window->Organizer and, from the Devices pane, select my iPhone and click on Use this phone for development.

Easy solution, but was not immediately obvious to me

10 comments

  1. THANK YOU! that was fantastic! i have been trying to figure this out for a week!

  2. Spent all day yesterday trying various solutions and this is all that was needed. Thank you!

  3. Glad to hear it helped!

  4. Man! Thank you very much you saved my night :D I love you

  5. Thank you so much!

  6. And still useful. After iOS 6 upgrade this was driving me mad….thank you!

  7. Thank you! I have spent days on this problem!

  8. You saved the day mate. Thank you very much.

Leave a comment